knockout@2.3.0 vulnerabilities

Knockout makes it easier to create rich, responsive UIs with JavaScript

Direct Vulnerabilities

Known vulnerabilities in the knockout package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • M
Cross-site Scripting (XSS)

knockout is a JavaScript MVVM (a modern variant of MVC) library that makes it easier to create rich, desktop-like user interfaces with JavaScript and HTML.

Affected versions of this package are vulnerable to Cross-site Scripting (XSS) due to not escaping the name attribute.

How to fix Cross-site Scripting (XSS)?

Upgrade knockout to version 3.5.0-beta or higher.

<3.5.0-beta
  • M
Cross-site Scripting (XSS)

knockout makes it easier to create rich, responsive UIs with JavaScript.

Affected versions of the package are vulnerable to Cross-site Scripting (XSS).

How to fix Cross-site Scripting (XSS)?

Upgrade knockout to version 3.0.0 or higher.

>=2.1.0-pre <3.0.0