mailsplit@4.0.2 vulnerabilities

Split email messages into an object stream

Direct Vulnerabilities

Known vulnerabilities in the mailsplit package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • H
Denial of Service (DoS)

mailsplit is an email parser.

Affected versions of this package are vulnerable to Denial of Service (DoS) attacks via a crafted email containing a few million multiparts.

MIME (Multipurpose Internet Mail Extentions) is an internet standard that extends the format of email to support: Non-ACSII character sets, non-text attachments, and more.

Most Node.js MIME decoders do not validate the number of multiparts they are willing to decode, allowing an attacker to send a crafted email containing a few million multiparts, which will then block the Node.js event loop for tens of seconds, explode RAM usage, and cause an out of memory crash.

How to fix Denial of Service (DoS)?

Upgrade mailsplit to version 4.2.1 or higher.

<4.2.1
  • H
Denial of Service (DoS)

mailsplit is an email parser.

Affected versions of this package are vulnerable to Denial of Service (DoS) attacks via a crafted email containing a few million multiparts.

MIME (Multipurpose Internet Mail Extentions) is an internet standard that extends the format of email to support: Non-ACSII character sets, non-text attachments, and more.

Most Node.js MIME decoders do not validate the number of multiparts they are willing to decode, allowing an attacker to send a crafted email containing a few million multiparts, which will then block the Node.js event loop for tens of seconds, explode RAM usage, and cause an out of memory crash.

How to fix Denial of Service (DoS)?

Upgrade mailsplit to version 4.2.1 or higher.

<4.2.1