memjs@0.2.0 vulnerabilities

A memcache client for node using the binary protocol and SASL authentication

Direct Vulnerabilities

Known vulnerabilities in the memjs package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • C
Denial of Service (DoS)

memjs is a pure Node.js client library for using memcache, in particular, the MemCachier service.

Affected versions of this package are vulnerable to Denial of Service (DoS) attacks due to allocating and storing buffers on typed input.

How to fix Denial of Service (DoS)?

There is no fix version for memjs.

<1.2.2