mime@1.3.5 vulnerabilities

Direct Vulnerabilities

Known vulnerabilities in the mime package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • L
Regular Expression Denial of Service (ReDoS)

mime is a comprehensive, compact MIME type module.

Affected versions of this package are vulnerable to Regular Expression Denial of Service (ReDoS). It uses regex the following regex /.*[\.\/\\]/ in its lookup, which can cause a slowdown of 2 seconds for 50k characters.

How to fix Regular Expression Denial of Service (ReDoS)?

Upgrade mime to version 1.4.1, 2.0.3 or higher.

<1.4.1 >=2.0.0 <2.0.3