node-addon-api@0.6.2 vulnerabilities

Node.js API (Node-API)

Direct Vulnerabilities

Known vulnerabilities in the node-addon-api package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • M
Remote Memory Exposure

node-addon-api is a This module contains header-only C++ wrapper classes which simplify the use of the C based N-API provided by Node.js when using C++. It provides a C++ object model and exception handling semantics with low overhead.

Affected versions of this package are vulnerable to Remote Memory Exposure via the napi_get_value_string_utf8, napi_get_value_string_latin1 and napi_get_value_string_utf16 functions.

How to fix Remote Memory Exposure?

Upgrade node-addon-api to version 1.7.2, 2.0.1 or higher.

>=0.0.0 <1.7.2 >=2.0.0 <2.0.1