node-uuid@1.3.0 vulnerabilities

Rigorous implementation of RFC4122 (v1 and v4) UUIDs.

Direct Vulnerabilities

Known vulnerabilities in the node-uuid package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • M
Denial of Service (DoS)

node-uuid is a Simple, fast generation of RFC4122 UUIDS.

Affected versions of the package are vulnerable to Denial of Service (DoS) attacks. While padding strings to zero out excess bytes, the pointer was not properly incremented.

How to fix Denial of Service (DoS)?

Upgrade node-uuid to version 1.3.1 or higher.

<1.3.1
  • M
Denial of Service (DoS)

node-uuid is a Simple, fast generation of RFC4122 UUIDS.

Affected versions of the package are vulnerable to Denial of Service (DoS) attacks. While padding strings to zero out excess bytes, the pointer was not properly incremented.

How to fix Denial of Service (DoS)?

Upgrade node-uuid to version 1.3.1 or higher.

<1.3.1
  • M
Insecure Randomness

node-uuid is a Simple, fast generation of RFC4122 UUIDS.

Affected versions of this package are vulnerable to Insecure Randomness. It uses the cryptographically insecure Math.random which can produce predictable values and should not be used in security-sensitive context.

How to fix Insecure Randomness?

Upgrade node-uuid to version 1.4.4 or greater.

<1.4.4
  • M
Insecure Randomness

node-uuid is a Simple, fast generation of RFC4122 UUIDS.

Affected versions of this package are vulnerable to Insecure Randomness. It uses the cryptographically insecure Math.random which can produce predictable values and should not be used in security-sensitive context.

How to fix Insecure Randomness?

Upgrade node-uuid to version 1.4.4 or greater.

<1.4.4