ssri@3.0.2 vulnerabilities

Standard Subresource Integrity library -- parses, serializes, generates, and verifies integrity metadata according to the SRI spec.

Direct Vulnerabilities

Known vulnerabilities in the ssri package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • M
Regular Expression Denial of Service (ReDoS)

ssri is a Standard Subresource Integrity library -- parses, serializes, generates, and verifies integrity metadata according to the SRI spec.

Affected versions of this package are vulnerable to Regular Expression Denial of Service (ReDoS) attacks. It used a regular expression (^([^-]+)-([A-Za-z0-9+/]+(?:=?=?))([?\\x21-\\x7E]*)$) in order to match SRI hashes. This can cause an impact of about 10 seconds matching time for data 50k characters long.

How to fix Regular Expression Denial of Service (ReDoS)?

Upgrade ssri to version 5.2.2 or higher.

<5.2.2