zsa vulnerabilities

`zsa` is a library for building typesafe server actions in Next.js. It provides a simple, scalable developer experience with features like validated inputs/outputs, procedures (middleware) for passing context to server actions, and React Query integration

Direct Vulnerabilities

Known vulnerabilities in the zsa package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • M
Generation of Error Message Containing Sensitive Information

<0.3.3

Package versions

1 - 14 of 14 Results
version published direct vulnerabilities
0.4.0 21 Jun, 2024
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
0.3.5 17 Jun, 2024
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
0.3.4 8 Jun, 2024
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
0.3.3 6 Jun, 2024
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
0.3.2 6 Jun, 2024
  • 0
    C
  • 0
    H
  • 1
    M
  • 0
    L
0.3.1 4 Jun, 2024
  • 0
    C
  • 0
    H
  • 1
    M
  • 0
    L
0.3.0 3 Jun, 2024
  • 0
    C
  • 0
    H
  • 1
    M
  • 0
    L
0.2.3 1 Jun, 2024
  • 0
    C
  • 0
    H
  • 1
    M
  • 0
    L
0.2.2 30 May, 2024
  • 0
    C
  • 0
    H
  • 1
    M
  • 0
    L
0.2.1 30 May, 2024
  • 0
    C
  • 0
    H
  • 1
    M
  • 0
    L
0.2.0 30 May, 2024
  • 0
    C
  • 0
    H
  • 1
    M
  • 0
    L
0.1.1 26 May, 2024
  • 0
    C
  • 0
    H
  • 1
    M
  • 0
    L
0.1.0 20 May, 2024
  • 0
    C
  • 0
    H
  • 1
    M
  • 0
    L
0.0.1 15 May, 2024
  • 0
    C
  • 0
    H
  • 1
    M
  • 0
    L