system.net.security vulnerabilities

Provides types, such as System.Net.Security.SslStream, that uses SSL/TLS protocols to provide secure network communication between client and server endpoints. Commonly Used Types: System.Net.Security.SslStream System.Net.Security.ExtendedProtectionPolicy When using NuGet 3.x this package requires at least version 3.4.

Direct Vulnerabilities

Known vulnerabilities in the system.net.security package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • H
Privilege Escalation

(,4.0.1) [4.3,4.3.1)
  • H
Improper Certificate Validation

(,4.0.1) [4.3,4.3.1)
  • M
Authentication Bypass

(,4.0.1) [4.3,4.3.1)
  • H
Denial of Service (DoS)

(,4.0.1) [4.3,4.3.1)