OS Command Injection Affecting python3-gpsd package, versions <1:3.26.1-3.el10_2.1


Severity

Recommended
high

Based on AlmaLinux security rating.

Threat Intelligence

EPSS
2.86% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALMALINUX10-PYTHON3GPSD-18609958
  • published11 Aug 2026
  • disclosed6 Aug 2026

Introduced: 6 Aug 2026

CVE-2026-58459  (opens in a new tab)
CWE-78  (opens in a new tab)

How to fix?

Upgrade AlmaLinux:10 python3-gpsd to version 1:3.26.1-3.el10_2.1 or higher.
This issue was patched in ALSA-2026:51075.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python3-gpsd package and not the python3-gpsd package as distributed by AlmaLinux. See How to fix? for AlmaLinux:10 relevant fixed versions and status.

gpsd through release-3.27.5, fixed at commit 4c06658, contains a command injection vulnerability in gpsprof that allows attackers who control the GPS device subtype value to execute arbitrary shell commands by embedding backtick payloads in the gnuplot plot title without proper escaping. The subtype field sourced from a DEVICES JSON log entry or NMEA PGRMT sentence is written into a generated gnuplot program via a set title statement with only double-quote characters escaped, enabling arbitrary shell command execution as the user running gnuplot when the victim renders the generated plot through the gpsprof and gnuplot workflow.

CVSS Base Scores

version 3.1