Use of Incorrectly-Resolved Name or Reference Affecting container-tools:1.0/python-podman-api package, versions <0:1.2.0-0.2.gitd0a45fe.module_el8.5.0+2635+e4386a39


Severity

Recommended
medium

Based on AlmaLinux security rating.

Threat Intelligence

EPSS
0.43% (36th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALMALINUX8-CONTAINERTOOLS-5626522
  • published28 May 2023
  • disclosed28 Apr 2020

Introduced: 28 Apr 2020

CVE-2019-19921  (opens in a new tab)
CWE-706  (opens in a new tab)

How to fix?

Upgrade AlmaLinux:8 container-tools:1.0/python-podman-api to version 0:1.2.0-0.2.gitd0a45fe.module_el8.5.0+2635+e4386a39 or higher.
This issue was patched in ALSA-2020:1650.

NVD Description

Note: Versions mentioned in the description apply only to the upstream container-tools:1.0/python-podman-api package and not the container-tools:1.0/python-podman-api package as distributed by AlmaLinux. See How to fix? for AlmaLinux:8 relevant fixed versions and status.

runc through 1.0.0-rc9 has Incorrect Access Control leading to Escalation of Privileges, related to libcontainer/rootfs_linux.go. To exploit this, an attacker must be able to spawn two containers with custom volume-mount configurations, and be able to run custom images. (This vulnerability does not affect Docker due to an implementation detail that happens to block the attack.)

References

CVSS Base Scores

version 3.1