CVE-2025-66293 Affecting java-1.8.0-openjdk package, versions <1:1.8.0.492.b09-1.el8


Severity

Recommended
high

Based on AlmaLinux security rating.

Threat Intelligence

EPSS
0.35% (29th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALMALINUX8-JAVA180OPENJDK-21744318
  • published27 Oct 2026
  • disclosed7 Jan 2026

Introduced: 7 Jan 2026

CVE-2025-66293  (opens in a new tab)

How to fix?

Upgrade AlmaLinux:8 java-1.8.0-openjdk to version 1:1.8.0.492.b09-1.el8 or higher.
This issue was patched in ALSA-2026:9683.

NVD Description

Note: Versions mentioned in the description apply only to the upstream java-1.8.0-openjdk package and not the java-1.8.0-openjdk package as distributed by AlmaLinux. See How to fix? for AlmaLinux:8 relevant fixed versions and status.

LIBPNG is a reference library for use in applications that read, create, and manipulate PNG (Portable Network Graphics) raster image files. Prior to 1.6.52, an out-of-bounds read vulnerability in libpng's simplified API allows reading up to 1012 bytes beyond the png_sRGB_base[512] array when processing valid palette PNG images with partial transparency and gamma correction. The PNG files that trigger this vulnerability are valid per the PNG specification; the bug is in libpng's internal state management. Upgrade to libpng 1.6.52 or later.

CVSS Base Scores

version 3.1