Out-of-Bounds Affecting net-snmp package, versions <1:5.8-33.el8_10


Severity

Recommended
high

Based on AlmaLinux security rating.

Threat Intelligence

EPSS
42.36% (99th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALMALINUX8-NETSNMP-15046079
  • published21 Jan 2026
  • disclosed15 Jan 2026

Introduced: 15 Jan 2026

CVE-2025-68615  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade AlmaLinux:8 net-snmp to version 1:5.8-33.el8_10 or higher.
This issue was patched in ALSA-2026:0750.

NVD Description

Note: Versions mentioned in the description apply only to the upstream net-snmp package and not the net-snmp package as distributed by AlmaLinux. See How to fix? for AlmaLinux:8 relevant fixed versions and status.

net-snmp is a SNMP application library, tools and daemon. Prior to versions 5.9.5 and 5.10.pre2, a specially crafted packet to an net-snmp snmptrapd daemon can cause a buffer overflow and the daemon to crash. This issue has been patched in versions 5.9.5 and 5.10.pre2.

CVSS Base Scores

version 3.1