Out-of-bounds Write Affecting pixman-devel package, versions <0:0.38.4-2.el8


Severity

Recommended
medium

Based on AlmaLinux security rating.

Threat Intelligence

EPSS
1.06% (64th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALMALINUX8-PIXMANDEVEL-5633882
  • published28 May 2023
  • disclosed10 May 2022

Introduced: 10 May 2022

CVE-2020-35492  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade AlmaLinux:8 pixman-devel to version 0:0.38.4-2.el8 or higher.
This issue was patched in ALSA-2022:1961.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pixman-devel package and not the pixman-devel package as distributed by AlmaLinux. See How to fix? for AlmaLinux:8 relevant fixed versions and status.

A flaw was found in cairo's image-compositor.c in all versions prior to 1.17.4. This flaw allows an attacker who can provide a crafted input file to cairo's image-compositor (for example, by convincing a user to open a file in an application using cairo, or if an application uses cairo on untrusted input) to cause a stack buffer overflow -> out-of-bounds WRITE. The highest impact from this vulnerability is to confidentiality, integrity, as well as system availability.

CVSS Base Scores

version 3.1