Improper Authentication Affecting tomcat-docs-webapp package, versions <1:9.0.121-1.el8_10


Severity

Recommended
high

Based on AlmaLinux security rating.

Threat Intelligence

EPSS
0.46% (38th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALMALINUX8-TOMCATDOCSWEBAPP-22100761
  • published31 Oct 2026
  • disclosed29 Oct 2026

Introduced: 29 Oct 2026

NewCVE-2026-68569  (opens in a new tab)
CWE-287  (opens in a new tab)

How to fix?

Upgrade AlmaLinux:8 tomcat-docs-webapp to version 1:9.0.121-1.el8_10 or higher.
This issue was patched in ALSA-2026:92869.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tomcat-docs-webapp package and not the tomcat-docs-webapp package as distributed by AlmaLinux. See How to fix? for AlmaLinux:8 relevant fixed versions and status.

Improper Authentication vulnerability in Apache Tomcat meant that in some circumstances (e.g. CLIENT-CERT, SPNEGO) that a user would be authenticated even if the user did not exist in the DataSourceRealm.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.0.M1 through 9.0.120.

The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other unsupported versions may also be affected.

Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.

CVSS Base Scores

version 3.1