Cross-site Scripting (XSS) Affecting xmlrpc-c package, versions <0:1.51.0-11.el8_10.1


Severity

Recommended
high

Based on AlmaLinux security rating.

Threat Intelligence

EPSS
0.28% (21st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALMALINUX8-XMLRPCC-19651707
  • published9 Sept 2026
  • disclosed31 Aug 2026

Introduced: 31 Aug 2026

CVE-2026-15928  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade AlmaLinux:8 xmlrpc-c to version 0:1.51.0-11.el8_10.1 or higher.
This issue was patched in ALSA-2026:64772.

NVD Description

Note: Versions mentioned in the description apply only to the upstream xmlrpc-c package and not the xmlrpc-c package as distributed by AlmaLinux. See How to fix? for AlmaLinux:8 relevant fixed versions and status.

XMLRPC-C Library versions 1.07 through 1.67.01 are vulnerable to a reflected cross-site scripting (XSS) vulnerability in the error page component.

CVSS Base Scores

version 3.1