HTTP Request Smuggling Affecting tomcat-webapps package, versions <1:9.0.117-1.el9_8


Severity

Recommended
high

Based on AlmaLinux security rating.

Threat Intelligence

EPSS
0.7% (53rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALMALINUX9-TOMCATWEBAPPS-21748139
  • published27 Oct 2026
  • disclosed11 Jun 2026

Introduced: 11 Jun 2026

CVE-2026-24880  (opens in a new tab)
CWE-444  (opens in a new tab)

How to fix?

Upgrade AlmaLinux:9 tomcat-webapps to version 1:9.0.117-1.el9_8 or higher.
This issue was patched in ALSA-2026:26323.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tomcat-webapps package and not the tomcat-webapps package as distributed by AlmaLinux. See How to fix? for AlmaLinux:9 relevant fixed versions and status.

Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling') vulnerability in Apache Tomcat via invalid chunk extension.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.1.0-M1 through 10.1.52, from 9.0.0.M1 through 9.0.115, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other, unsupported versions may also be affected.

Users are recommended to upgrade to version 11.0.20, 10.1.52 or 9.0.116, which fix the issue.

CVSS Base Scores

version 3.1