CVE-2022-45060 Affecting varnish-docs package, versions <0:6.6.2-2.el9_1.1


Severity

Recommended
0.0
high
0
10

Based on AlmaLinux security rating.

Threat Intelligence

EPSS
1.04% (64th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALMALINUX9-VARNISHDOCS-5618528
  • published28 May 2023
  • disclosed28 Nov 2022

Introduced: 28 Nov 2022

CVE-2022-45060  (opens in a new tab)

How to fix?

Upgrade AlmaLinux:9 varnish-docs to version 0:6.6.2-2.el9_1.1 or higher.
This issue was patched in ALSA-2022:8643.

NVD Description

Note: Versions mentioned in the description apply only to the upstream varnish-docs package and not the varnish-docs package as distributed by AlmaLinux. See How to fix? for AlmaLinux:9 relevant fixed versions and status.

An HTTP Request Forgery issue was discovered in Varnish Cache 5.x and 6.x before 6.0.11, 7.x before 7.1.2, and 7.2.x before 7.2.1. An attacker may introduce characters through HTTP/2 pseudo-headers that are invalid in the context of an HTTP/1 request line, causing the Varnish server to produce invalid HTTP/1 requests to the backend. This could, in turn, be used to exploit vulnerabilities in a server behind the Varnish server. Note: the 6.0.x LTS series (before 6.0.11) is affected.

CVSS Base Scores

version 3.1