CVE-2025-29480 Affecting gdal package, versions <3.10.3-r0


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.24% (15th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE322-GDAL-10279183
  • published31 May 2025
  • disclosed7 Apr 2025

Introduced: 7 Apr 2025

CVE-2025-29480  (opens in a new tab)

How to fix?

Upgrade Alpine:3.22 gdal to version 3.10.3-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gdal package and not the gdal package as distributed by Alpine. See How to fix? for Alpine:3.22 relevant fixed versions and status.

Buffer Overflow vulnerability in gdal 3.10.2 allows a local attacker to cause a denial of service via the OGRSpatialReference::Release function. NOTE: the Supplier indicates that the report is invalid and could not be reproduced.

CVSS Base Scores

version 3.1