Integer Overflow or Wraparound Affecting ruby package, versions <3.4.12-r0


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

Exploit Maturity
Attacked
EPSS
18.43% (98th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE322-RUBY-21830465
  • published30 Oct 2026
  • disclosed13 Oct 2026

Introduced: 13 Oct 2026

NewCVE-2026-97229  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Alpine:3.22 ruby to version 3.4.12-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby package and not the ruby package as distributed by Alpine. See How to fix? for Alpine:3.22 relevant fixed versions and status.

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.2 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an unauthenticated user to execute arbitrary code on the GitLab server via a specially crafted regular expression in a CI/CD configuration, due to insufficient regular expression validation.

CVSS Base Scores

version 3.1