CVE-2026-79611 Affecting xen package, versions <4.20.4-r2


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.16% (6th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE322-XEN-20887298
  • published14 Oct 2026
  • disclosed13 Oct 2026

Introduced: 13 Oct 2026

NewCVE-2026-79611  (opens in a new tab)

How to fix?

Upgrade Alpine:3.22 xen to version 4.20.4-r2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream xen package and not the xen package as distributed by Alpine. See How to fix? for Alpine:3.22 relevant fixed versions and status.

For XSA-308 logic was introduced, as VMX VMEntry checks do not like the exact combination of state which occurs when #DB in intercepted, Single Stepping is active, and blocked by STI/MovSS is active, despite this being a legitimate state to be in. The resulting VMEntry failure is fatal to the guest.

Sadly there is another special sub-case of the above, with branch tracing enabled. In that case the prior adjustment would still cause a VMentry failure, as before fatal to the guest.

CVSS Base Scores

version 3.1