Directory Traversal Affecting pnpm package, versions <10.33.4-r0


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.61% (49th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE323-PNPM-16875053
  • published26 May 2026
  • disclosed28 Jan 2026

Introduced: 28 Jan 2026

CVE-2026-24842  (opens in a new tab)
CWE-22  (opens in a new tab)
CWE-59  (opens in a new tab)

How to fix?

Upgrade Alpine:3.23 pnpm to version 10.33.4-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pnpm package and not the pnpm package as distributed by Alpine. See How to fix? for Alpine:3.23 relevant fixed versions and status.

node-tar,a Tar for Node.js, contains a vulnerability in versions prior to 7.5.7 where the security check for hardlink entries uses different path resolution semantics than the actual hardlink creation logic. This mismatch allows an attacker to craft a malicious TAR archive that bypasses path traversal protections and creates hardlinks to arbitrary files outside the extraction directory. Version 7.5.7 contains a fix for the issue.

CVSS Base Scores

version 3.1