CVE-2026-14739 Affecting perl-dbi package, versions <1.651-r0


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.41% (35th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE324-PERLDBI-18310117
  • published26 Jul 2026
  • disclosed7 Jul 2026

Introduced: 7 Jul 2026

CVE-2026-14739  (opens in a new tab)

How to fix?

Upgrade Alpine:3.24 perl-dbi to version 1.651-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream perl-dbi package and not the perl-dbi package as distributed by Alpine. See How to fix? for Alpine:3.24 relevant fixed versions and status.

DBI versions before 1.650 for Perl have a heap overflow when preparsing SQL statements with an extreme number of placeholders.

The fix for CVE-2026-10879 did not allocate enough memory to handle approximately 1.2-million placeholders.

DBI version 1.650 sets a hard limit of 99,999 placeholders.

CVSS Base Scores

version 3.1