Buffer Over-read Affecting tomcat-native package, versions <2.0.16-r0


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.56% (47th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ALPINE324-TOMCATNATIVE-21603023
  • published23 Oct 2026
  • disclosed23 Sept 2026

Introduced: 23 Sep 2026

CVE-2026-86243  (opens in a new tab)
CWE-126  (opens in a new tab)

How to fix?

Upgrade Alpine:3.24 tomcat-native to version 2.0.16-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tomcat-native package and not the tomcat-native package as distributed by Alpine. See How to fix? for Alpine:3.24 relevant fixed versions and status.

Buffer over-read vulnerability in Apache Tomcat Native during the TLS handshake permits a malicious user to trigger a DoS via a JVM crash.

This issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Earlier, unsupported versions may also be affected.

Users are recommended to upgrade to version 1.3.9 or 2.0.16, which fix the issue.

CVSS Base Scores

version 3.1