Out-of-bounds Write Affecting ghostscript-doc package, versions <0:9.54.0-9.amzn2.0.14


Severity

Recommended
0.0
high
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
0.32% (25th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN2-GHOSTSCRIPTDOC-21696823
  • published25 Oct 2026
  • disclosed30 Sept 2026

Introduced: 30 Sep 2026

NewCVE-2026-103226  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2 ghostscript-doc to version 0:9.54.0-9.amzn2.0.14 or higher.
This issue was patched in ALAS2-2026-4034.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ghostscript-doc package and not the ghostscript-doc package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2 relevant fixed versions and status.

A vulnerability was identified in Artifex Ghostscript up to 10.07.0. Affected is the function type1_callsubr of the file devices/vector/gdevpsfx.c of the component Pdfwrite. The manipulation leads to stack-based buffer overflow. Remote exploitation of the attack is possible. The exploit is publicly available and might be used. Upgrading to version 10.08.0 is able to address this issue. It is suggested to upgrade the affected component. A solution was implemented: "I've chosen to fix this slightly differently by using the defined macro in the font parsing loop rather than in the callsubr function, because this better matches the pattern of 'normal' usage."

CVSS Base Scores

version 3.1