Resource Exhaustion Affecting libuv package, versions <1:1.39.0-1.amzn2


Severity

Recommended
0.0
high
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
8.36% (95th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN2-LIBUV-1692898
  • published27 Sept 2021
  • disclosed18 Sept 2020

Introduced: 18 Sep 2020

CVE-2020-8251  (opens in a new tab)
CWE-400  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2 libuv to version 1:1.39.0-1.amzn2 or higher.
This issue was patched in ALAS2-2021-1581.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libuv package and not the libuv package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2 relevant fixed versions and status.

Node.js < 14.11.0 is vulnerable to HTTP denial of service (DoS) attacks based on delayed requests submission which can make the server unable to accept new connections.

CVSS Base Scores

version 3.1