Improper Authentication Affecting PackageKit package, versions <0:1.1.5-2.amzn2.0.1


Severity

Recommended
0.0
medium
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
0.38% (30th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN2-PACKAGEKIT-1662542
  • published27 Sept 2021
  • disclosed23 Apr 2018

Introduced: 23 Apr 2018

CVE-2018-1106  (opens in a new tab)
CWE-287  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2 PackageKit to version 0:1.1.5-2.amzn2.0.1 or higher.
This issue was patched in ALAS2-2018-1006.

NVD Description

Note: Versions mentioned in the description apply only to the upstream PackageKit package and not the PackageKit package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2 relevant fixed versions and status.

An authentication bypass flaw has been found in PackageKit before 1.1.10 that allows users without administrator privileges to install signed packages. A local attacker can use this vulnerability to install vulnerable packages to further compromise a system.