Resource Exhaustion Affecting python3-pygments package, versions <0:2.2.0-3.amzn2.0.3


Severity

Recommended
medium

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
3.91% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN2-PYTHON3PYGMENTS-5789370
  • published20 Jul 2023
  • disclosed17 Mar 2021

Introduced: 17 Mar 2021

CVE-2021-27291  (opens in a new tab)
CWE-400  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2 python3-pygments to version 0:2.2.0-3.amzn2.0.3 or higher.
This issue was patched in ALAS2-2023-2117.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python3-pygments package and not the python3-pygments package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2 relevant fixed versions and status.

In pygments 1.1+, fixed in 2.7.4, the lexers used to parse programming languages rely heavily on regular expressions. Some of the regular expressions have exponential or cubic worst-case complexity and are vulnerable to ReDoS. By crafting malicious input, an attacker can cause a denial of service.

CVSS Base Scores

version 3.1