CVE-2018-8088 Affecting slf4j-manual package, versions <0:1.7.4-4.amzn2


Severity

Recommended
0.0
high
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
14.7% (97th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN2-SLF4JMANUAL-1662176
  • published27 Sept 2021
  • disclosed20 Mar 2018

Introduced: 20 Mar 2018

CVE-2018-8088  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2 slf4j-manual to version 0:1.7.4-4.amzn2 or higher.
This issue was patched in ALAS2-2018-999.

NVD Description

Note: Versions mentioned in the description apply only to the upstream slf4j-manual package and not the slf4j-manual package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2 relevant fixed versions and status.

org.slf4j.ext.EventData in the slf4j-ext module in QOS.CH SLF4J before 1.8.0-beta2 allows remote attackers to bypass intended access restrictions via crafted data. EventData in the slf4j-ext module in QOS.CH SLF4J, has been fixed in SLF4J versions 1.7.26 later and in the 2.0.x series.

References

CVSS Base Scores

version 3.1