Resource Exhaustion Affecting snakeyaml package, versions <0:1.11-8.amzn2.0.1


Severity

Recommended
0.0
high
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
2.93% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN2-SNAKEYAML-3343211
  • published7 Mar 2023
  • disclosed30 Aug 2022

Introduced: 30 Aug 2022

CVE-2022-25857  (opens in a new tab)
CWE-400  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2 snakeyaml to version 0:1.11-8.amzn2.0.1 or higher.
This issue was patched in ALAS2-2023-1976.

NVD Description

Note: Versions mentioned in the description apply only to the upstream snakeyaml package and not the snakeyaml package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2 relevant fixed versions and status.

The package org.yaml:snakeyaml from 0 and before 1.31 are vulnerable to Denial of Service (DoS) due missing to nested depth limitation for collections.

CVSS Base Scores

version 3.1