Insufficient Session Expiration The advisory has been revoked - it doesn't affect any version of package unbound-libs  (opens in a new tab)


Threat Intelligence

EPSS
1.16% (67th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN2-UNBOUNDLIBS-6229160
  • published6 Feb 2024
  • disclosed1 Aug 2022

Introduced: 1 Aug 2022

CVE-2022-30699  (opens in a new tab)
CWE-613  (opens in a new tab)

Amendment

The Amazon-Linux security team deemed this advisory irrelevant for Amazon-Linux:2.

NVD Description

Note: Versions mentioned in the description apply only to the upstream unbound-libs package and not the unbound-libs package as distributed by Amazon-Linux.

NLnet Labs Unbound, up to and including version 1.16.1, is vulnerable to a novel type of the "ghost domain names" attack. The vulnerability works by targeting an Unbound instance. Unbound is queried for a rogue domain name when the cached delegation information is about to expire. The rogue nameserver delays the response so that the cached delegation information is expired. Upon receiving the delayed answer containing the delegation information, Unbound overwrites the now expired entries. This action can be repeated when the delegation information is about to expire making the rogue delegation information ever-updating. From version 1.16.2 on, Unbound stores the start time for a query and uses that to decide if the cached delegation information can be overwritten.