Out-of-bounds Write Affecting zsh package, versions <0:5.5.1-1.amzn2


Severity

Recommended
medium

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
0.43% (36th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN2-ZSH-1662778
  • published27 Sept 2021
  • disclosed9 Mar 2018

Introduced: 9 Mar 2018

CVE-2018-1071  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2 zsh to version 0:5.5.1-1.amzn2 or higher.
This issue was patched in ALAS2-2018-1013.

NVD Description

Note: Versions mentioned in the description apply only to the upstream zsh package and not the zsh package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2 relevant fixed versions and status.

zsh through version 5.4.2 is vulnerable to a stack-based buffer overflow in the exec.c:hashcmd() function. A local attacker could exploit this to cause a denial of service.

CVSS Base Scores

version 3.1