Improper Input Validation Affecting chkrootkit package, versions <0:0.49-9.8.amzn1


Severity

Recommended
high

Based on Amazon Linux security rating.

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
3.83% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-CHKROOTKIT-1675616
  • published27 Sept 2021
  • disclosed25 Oct 2014

Introduced: 25 Oct 2014

CVE-2014-0476  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 chkrootkit to version 0:0.49-9.8.amzn1 or higher.
This issue was patched in ALAS-2014-370.

NVD Description

Note: Versions mentioned in the description apply only to the upstream chkrootkit package and not the chkrootkit package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

The slapper function in chkrootkit before 0.50 does not properly quote file paths, which allows local users to execute arbitrary code via a Trojan horse executable. NOTE: this is only a vulnerability when /tmp is not mounted with the noexec option.

CVSS Base Scores

version 3.1