Improper Input Validation Affecting compat-openldap package, versions <1:2.3.43-2.5.amzn1


Severity

Recommended
high

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
18.82% (98th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-COMPATOPENLDAP-1690382
  • published27 Sept 2021
  • disclosed11 Sept 2015

Introduced: 11 Sep 2015

CVE-2015-6908  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 compat-openldap to version 1:2.3.43-2.5.amzn1 or higher.
This issue was patched in ALAS-2015-599.

NVD Description

Note: Versions mentioned in the description apply only to the upstream compat-openldap package and not the compat-openldap package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

The ber_get_next function in libraries/liblber/io.c in OpenLDAP 2.4.42 and earlier allows remote attackers to cause a denial of service (reachable assertion and application crash) via crafted BER data, as demonstrated by an attack against slapd.

CVSS Base Scores

version 3.1