Out-of-Bounds Affecting cvs package, versions <0:1.11.23-11.6.amzn1


Severity

Recommended
0.0
medium
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
8.37% (95th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-CVS-1663750
  • published27 Sept 2021
  • disclosed29 May 2012

Introduced: 29 May 2012

CVE-2012-0804  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 cvs to version 0:1.11.23-11.6.amzn1 or higher.
This issue was patched in ALAS-2012-51.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cvs package and not the cvs package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

Heap-based buffer overflow in the proxy_connect function in src/client.c in CVS 1.11 and 1.12 allows remote HTTP proxy servers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted HTTP response.

CVSS Base Scores

version 3.1