Improper Verification of Cryptographic Signature Affecting dbus-doc package, versions <1:1.6.12-14.31.amzn1


Severity

Recommended
0.0
medium
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
1.12% (66th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-DBUSDOC-5441490
  • published21 Apr 2023
  • disclosed10 Oct 2022

Introduced: 10 Oct 2022

CVE-2022-42010  (opens in a new tab)
CWE-347  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 dbus-doc to version 1:1.6.12-14.31.amzn1 or higher.
This issue was patched in ALAS-2023-1730.

NVD Description

Note: Versions mentioned in the description apply only to the upstream dbus-doc package and not the dbus-doc package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

An issue was discovered in D-Bus before 1.12.24, 1.13.x and 1.14.x before 1.14.4, and 1.15.x before 1.15.2. An authenticated attacker can cause dbus-daemon and other programs that use libdbus to crash when receiving a message with certain invalid type signatures.

CVSS Base Scores

version 3.1