Out-of-bounds Write Affecting file-libs package, versions <0:5.34-3.37.amzn1


Severity

Recommended
0.0
medium
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
3.47% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-FILELIBS-1717806
  • published27 Sept 2021
  • disclosed18 Feb 2019

Introduced: 18 Feb 2019

CVE-2019-8907  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 file-libs to version 0:5.34-3.37.amzn1 or higher.
This issue was patched in ALAS-2019-1186.

NVD Description

Note: Versions mentioned in the description apply only to the upstream file-libs package and not the file-libs package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

do_core_note in readelf.c in libmagic.a in file 5.35 allows remote attackers to cause a denial of service (stack corruption and application crash) or possibly have unspecified other impact.