Resource Management Errors Affecting file-static package, versions <0:5.22-2.29.amzn1


Severity

Recommended
medium

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
2.98% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-FILESTATIC-1683465
  • published27 Sept 2021
  • disclosed21 Jan 2015

Introduced: 21 Jan 2015

CVE-2014-9621  (opens in a new tab)
CWE-399  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 file-static to version 0:5.22-2.29.amzn1 or higher.
This issue was patched in ALAS-2015-497.

NVD Description

Note: Versions mentioned in the description apply only to the upstream file-static package and not the file-static package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

The ELF parser in file 5.16 through 5.21 allows remote attackers to cause a denial of service via a long string.

CVSS Base Scores

version 3.1