Out-of-Bounds Affecting foomatic package, versions <0:4.0.4-5.11.amzn1


Severity

Recommended
0.0
medium
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
5.48% (93rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-FOOMATIC-1696473
  • published27 Sept 2021
  • disclosed15 Apr 2016

Introduced: 15 Apr 2016

CVE-2010-5325  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 foomatic to version 0:4.0.4-5.11.amzn1 or higher.
This issue was patched in ALAS-2016-690.

NVD Description

Note: Versions mentioned in the description apply only to the upstream foomatic package and not the foomatic package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

Heap-based buffer overflow in the unhtmlify function in foomatic-rip in foomatic-filters before 4.0.6 allows remote attackers to cause a denial of service (memory corruption and crash) or possibly execute arbitrary code via a long job title.

CVSS Base Scores

version 3.1