Heap-based Buffer Overflow Affecting ImageMagick-devel package, versions <0:6.9.10.97-1.26.amzn1


Severity

Recommended
0.0
medium
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
0.31% (24th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-IMAGEMAGICKDEVEL-5789772
  • published20 Jul 2023
  • disclosed4 Oct 2023

Introduced: 20 Jul 2023

CVE-2023-3428  (opens in a new tab)
CWE-122  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 ImageMagick-devel to version 0:6.9.10.97-1.26.amzn1 or higher.
This issue was patched in ALAS-2023-1781.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ImageMagick-devel package and not the ImageMagick-devel package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

A heap-based buffer overflow vulnerability was found in coders/tiff.c in ImageMagick. This issue may allow a local attacker to trick the user into opening a specially crafted file, resulting in an application crash and denial of service.

CVSS Base Scores

version 3.1