Resource Exhaustion Affecting ImageMagick-perl package, versions <0:6.9.10.68-3.22.amzn1


Severity

Recommended
high

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
2.26% (81st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-IMAGEMAGICKPERL-6468034
  • published20 Mar 2024
  • disclosed26 Jun 2019

Introduced: 26 Jun 2019

CVE-2019-12975  (opens in a new tab)
CWE-400  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 ImageMagick-perl to version 0:6.9.10.68-3.22.amzn1 or higher.
This issue was patched in ALAS-2024-1926.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ImageMagick-perl package and not the ImageMagick-perl package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

ImageMagick 7.0.8-34 has a memory leak vulnerability in the WriteDPXImage function in coders/dpx.c.

CVSS Base Scores

version 3.1