Out-of-Bounds Affecting json-c package, versions <0:0.11-6.8.amzn1


Severity

Recommended
0.0
medium
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
4.31% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-JSONC-1677610
  • published27 Sept 2021
  • disclosed22 Apr 2014

Introduced: 22 Apr 2014

CVE-2013-6370  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 json-c to version 0:0.11-6.8.amzn1 or higher.
This issue was patched in ALAS-2014-416.

NVD Description

Note: Versions mentioned in the description apply only to the upstream json-c package and not the json-c package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

Buffer overflow in the printbuf APIs in json-c before 0.12 allows remote attackers to cause a denial of service via unspecified vectors.

CVSS Base Scores

version 3.1