OS Command Injection Affecting less package, versions <0:436-13.14.amzn1


Severity

Recommended
0.0
high
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
0.63% (46th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-LESS-8688937
  • published6 Feb 2025
  • disclosed13 Apr 2024

Introduced: 13 Apr 2024

CVE-2024-32487  (opens in a new tab)
CWE-78  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 less to version 0:436-13.14.amzn1 or higher.
This issue was patched in ALAS-2025-1958.

NVD Description

Note: Versions mentioned in the description apply only to the upstream less package and not the less package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

less through 653 allows OS command execution via a newline character in the name of a file, because quoting is mishandled in filename.c. Exploitation typically requires use with attacker-controlled file names, such as the files extracted from an untrusted archive. Exploitation also requires the LESSOPEN environment variable, but this is set by default in many common cases.

CVSS Base Scores

version 3.1