Arbitrary Command Injection Affecting less-debuginfo package, versions <0:436-13.13.amzn1


Severity

Recommended
0.0
high
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
1.06% (62nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-LESSDEBUGINFO-6371496
  • published5 Mar 2024
  • disclosed19 Feb 2024

Introduced: 19 Feb 2024

CVE-2022-48624  (opens in a new tab)
CWE-77  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 less-debuginfo to version 0:436-13.13.amzn1 or higher.
This issue was patched in ALAS-2024-1924.

NVD Description

Note: Versions mentioned in the description apply only to the upstream less-debuginfo package and not the less-debuginfo package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

close_altfile in filename.c in less before 606 omits shell_quote calls for LESSCLOSE.

CVSS Base Scores

version 3.1