Out-of-Bounds Affecting libexif-devel package, versions <0:0.6.21-5.6.amzn1


Severity

Recommended
0.0
medium
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
3.89% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-LIBEXIFDEVEL-1665430
  • published27 Sept 2021
  • disclosed13 Jul 2012

Introduced: 13 Jul 2012

CVE-2012-2812  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 libexif-devel to version 0:0.6.21-5.6.amzn1 or higher.
This issue was patched in ALAS-2012-126.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libexif-devel package and not the libexif-devel package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

The exif_entry_get_value function in exif-entry.c in the EXIF Tag Parsing Library (aka libexif) before 0.6.21 allows remote attackers to cause a denial of service (out-of-bounds read) or possibly obtain sensitive information from process memory via crafted EXIF tags in an image.

CVSS Base Scores

version 3.1