Integer Overflow or Wraparound Affecting libksba-debuginfo package, versions <0:1.3.5-1.11.amzn1


Severity

Recommended
0.0
high
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
1.67% (77th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-LIBKSBADEBUGINFO-5668887
  • published7 Jun 2023
  • disclosed20 Dec 2022

Introduced: 20 Dec 2022

CVE-2022-47629  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 libksba-debuginfo to version 0:1.3.5-1.11.amzn1 or higher.
This issue was patched in ALAS-2023-1752.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libksba-debuginfo package and not the libksba-debuginfo package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

Libksba before 1.6.3 is prone to an integer overflow vulnerability in the CRL signature parser.

CVSS Base Scores

version 3.1