Out-of-Bounds Affecting libproxy-bin package, versions <0:0.3.0-3.7.amzn1


Severity

Recommended
0.0
medium
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
3.22% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-LIBPROXYBIN-1666093
  • published27 Sept 2021
  • disclosed11 Nov 2012

Introduced: 11 Nov 2012

CVE-2012-4505  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 libproxy-bin to version 0:0.3.0-3.7.amzn1 or higher.
This issue was patched in ALAS-2012-140.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libproxy-bin package and not the libproxy-bin package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

Heap-based buffer overflow in the px_pac_reload function in lib/pac.c in libproxy 0.2.x and 0.3.x allows remote servers to have an unspecified impact via a crafted Content-Length size in an HTTP response header for a proxy.pac file request, a different vulnerability than CVE-2012-4504.

CVSS Base Scores

version 3.1