Out-of-bounds Write Affecting librabbitmq-devel package, versions <0:0.1-0.2.hgfb6fca832fd2.3.amzn1


Severity

Recommended
medium

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
3.32% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-LIBRABBITMQDEVEL-1722467
  • published27 Sept 2021
  • disclosed1 Dec 2019

Introduced: 1 Dec 2019

CVE-2019-18609  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 librabbitmq-devel to version 0:0.1-0.2.hgfb6fca832fd2.3.amzn1 or higher.
This issue was patched in ALAS-2020-1394.

NVD Description

Note: Versions mentioned in the description apply only to the upstream librabbitmq-devel package and not the librabbitmq-devel package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

An issue was discovered in amqp_handle_input in amqp_connection.c in rabbitmq-c 0.9.0. There is an integer overflow that leads to heap memory corruption in the handling of CONNECTION_STATE_HEADER. A rogue server could return a malicious frame header that leads to a smaller target_size value than needed. This condition is then carried on to a memcpy function that copies too much data into a heap buffer.

CVSS Base Scores

version 3.1