Incorrect Calculation of Buffer Size Affecting libtasn1 package, versions <0:2.3-6.6.amzn1


Severity

Recommended
0.0
medium
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
3.79% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-LIBTASN1-1674860
  • published27 Sept 2021
  • disclosed5 Jun 2014

Introduced: 5 Jun 2014

CVE-2014-3468  (opens in a new tab)
CWE-131  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 libtasn1 to version 0:2.3-6.6.amzn1 or higher.
This issue was patched in ALAS-2014-359.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libtasn1 package and not the libtasn1 package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

The asn1_get_bit_der function in GNU Libtasn1 before 3.6 does not properly report an error when a negative bit length is identified, which allows context-dependent attackers to cause out-of-bounds access via crafted ASN.1 data.

CVSS Base Scores

version 3.1